I was down MSY the other day with the intention of getting a new Wireless N Router, however as I was looking around I noticed there was a bunch of AMD 900 series based motherboards (the upgraded version of my current 800 series).

Among them was the Gigabyte 990FXA-UD3, which is essentially the updated version of my 880FXA except I have the the UD5 model which basically is geared more towards Multi-GPU set-ups (SLI/Crossfire). Since I have just the one card, the UD3 was a reasonable compromise considering the $50 difference.

Gigabyte 990FXA-UD3

Gigabyte 990FXA-UD3


Anyway I ended up getting it in the hopes that my TV Tuner issues would be solved. Yeah right!

So out with the old and in with the new; well maybe it wasn’t quite as simple as that, but anyway long story short I successfully swapped them out but in the process I managed to lose 1 pin on the CPU (it stayed in the socket) so that then forced me to find a replacement.


Naturally I wanted to upgrade in the process so I sought out the highly coveted AMD Phenom II 1090T 6-core 3.2GHz. MSY was my first thought, but they didn’t have any in stock in Australia, then I tried Landmark Computers, apparently they don’t sell AMD. So I tried a couple of local shops – CNET Technology and Centrecom. Nope.

In desperation I searched my usual internet based stores, first I tried PC Case Gear, which had it in stock, and I could also drive down and pick it up. Unfortunately they took too long to process the order, I cancelled and searched for a store that had a shop front with stock.

Eventually I stumbled across Scorptec Computers (Scorpion Technology Computers) which had the 1090T in stock, and also a shop front (closer that PCCG too). So I trundled off to Rowville, about a 40min journey via EastLink, got the processor (exceptional service there too) and I got it installed later that night.


Now after all that, one would expect/hope that the problem I sought to seek in the first place would have been fixed. But of course, me being me, it was not.

First boot was fine, all PCIe cards showed up, installed the drivers, no problems.

Then after the reboot, one was gone.

At this point I was 100% sure this has something to do with the use of a 1x PCIe card in a 16x/8x/4x slot so I started to experiment.

Test 001:

SLOT # from CPU Card Installed Result Notes
1 (1x) AverTV TwinStar PCI Bus 5
2 (16x) GTX275 PCI Bus 1
3 (1x) N/A
4 (4x) none
5 (16x) X-Fi PCI Bus 4
6 – PCI none
7 – (4x) DViCo FusionHDTV None/Not assigned No card detected
Reboots 3

As you can see, the Fusion card decided not to work when in the 4x (full length) slot.

Test 002:

SLOT # from CPU Card Installed Resulting Bus Notes
1 (1x) DViCo FusionHDTV PCI Bus 10
2 (16x) GTX275 PCI Bus 1
3 (1x) N/A
4 (4x) none
5 (16x) X-Fi PCI Bus 4
6 – PCI none
7 – (4x) AverTV TwinStar PCI Bus 5
Reboots 8
Day 4, think i’m in the clear

As you can see here, I swapped the 2 TV cards around and strange things happened.

Firstly, the TwinStar card retained the PCI Bus number that it had in the other slot. But what is most interesting to me is the DViCo card now has a new Bus number of 10.

I don’t pretend to understand the way these bus numbers are derived, I have no idea actually, but if they are indeed static per slot, then why did they change ?


I guess the most important thing here is that I now have 4 working tuners and I have not seen any bluescreens, crashes or other anomalies I’ve experienced in the past.


Once again, here’s to hoping it continues that way!

Until the next problem,